Wordpress

【WordPress5.3】JINの画像キャプションが左寄りで大きくなるのを解決したよ

クボヒロ

こんにちは、クボヒロです。
(@Kubohiro7)

WordPress5.3が11月12日にリリースされました。

それに伴い、JINテーマで画像のキャプション(説明)の装飾がなくなり、「中央寄りだったのが左寄りの文章に」、「文字サイズが小さかったのに大きく」なってしまいました。

今回はそういった症状の解決と、他にもWordpress5.3へアップデートしたことによる不便な点を挙げていこうと思います。(結果的にこちらも直ります。)

ちなみに、JINテーマに不具合があるというわけではなく、WordPress5.3からインライン画像の並びの仕組みが変わっているようでそれにJINテーマが対応していないだけのようです。

JINテーマで画像キャプションがおかしくなってしまう

上記の画像を見てもらうと分かると思うのですが、左の画像はWordpressのバージョンを5.3にした直後から、画像のキャプションが左寄り、文字サイズも大きくなってしまっています。(画像右が正しい表示)

そもそも画像キャプションとは・・・、画像の下に書くことができるコメントで、その画像がどんなものなのか書き込むことによって、より分かりやすい記事にするためのものです。

画像左のものだと、画像のキャプションというよりも通常の文章のように感じてしまいませんか?せっかくのキャプションなので、キャプションの装飾は普通の文章よりも「小さい文字サイズ・文字は中央寄り」というのが分かりやすくていいと思うんです。

クボヒロ

私は結構この画像キャプションを使っていたので、今回のWordpressアップデートで不便になっちゃったよー

WordPress5.3のアップデート内容について

WordPress5.3の更新内容は、下記のブログが分かりやすかったのでぜひご覧ください。

ざっくりいうと、画像のリサイズを自動でしてくれたり、一部のUIや、ブロックエディタのUIや挙動などが変わっています。

クボヒロ

今までなんてことなしにGutenbergブロックエディタを使っていた人でも、今回のアップデートによって「あれ?なんか変わっちゃった?」って感じると思うな

WordPress5.3での不便点

今回のアップデートにより、私が実際にWordpress5.3のGutenbergブロックエディタを使ってみて「ここが不便になった!」と感じた点を挙げていきます。

  1. ブロックエディタの挙動がもっさりする(処理速度落ちた?)
  2. 画像キャプションが書けない時がある(下のブロックとかぶってしまい書けない感じ)
  3. ブロックの移動がズレるようになった(連続して移動できないので不便)
  4. ブロックひとつひとつが大きくなって、画面を圧迫

ブロックエディタの挙動がもっさりする

ブロックエディタの挙動が全体的にもっさりになってしまいました。というより、アニメーションのようなものが追加されたようで、次へのアクションのテンポが悪いです。これは、気になる人は気になると思います。

画像キャプションが書けない時がある

画像キャプションが書けない時がたまにあります。私の場合、画像のサイズを変更すると書けない場合が多いです。

また、今回の画像キャプションの表示がおかしくなってしまう問題ですが、JINテーマが対応してくれれば直る可能性があります。

ブロックの移動がズレるようになった

ブロック横の矢印を上下にクリックすることにより、ブロックを移動することが出来ます。Wordpress更新前だったら連打するとどんどん移動出来たのですが、更新後は連打するとカーソルがずれてブロックの連続移動が出来なくなりました

ブロックを移動させるよりも、もはや1からブロックを作り直したほうが早く済んでしまいます・・・。

ブロックひとつひとつが大きくなって、画面を圧迫

▲ 更新前(すっきり!)
▲ 更新後(もっさり・・・)

WordPress5.3のブロックはひとつひとつ大きくなってしまいました。同じショートコードでも、上が更新前の画像で、下が更新後のものです。

ショートコードのブロックのみならず、他のブロックも大きくなってかさばるようになり、エディタ全体が圧迫感があり一覧性が悪くなってしまいました・・・。

プラグインで解決!バージョンを戻そう

今回の「JINテーマで画像キャプションがおかしくなる」のもそうですが、他にもWordpress5.3には不便点も多いため、前のバージョンに戻すのが解決法になります。

プラグインの使い方(設定)

プラグイン新規追加より、「WP Downgrade Specific Core Version」を検索してインストール>有効にしてください。(下記リンクからダウンロードしてもOKですよ)

設定から「WP Downgrade」に進み、「Wordpress Target Version:」というところに「5.2.4」と入力してください。

その後、変更を保存します。

どのバージョンに戻すかは下記を参照してください。2019/11月現在だと、5.2.4(5.3の一個手前)で問題ないと思います。

Releases – WordPress

「5.2.4」の更新が出てくるので、再インストールしてください。

「Wordpress5.2.4へようこそ」と出たら成功です。画像キャプションや、投稿エディタも戻っています。

あとがき

JINテーマに不具合があるというわけではなく、WordPress5.3からインライン画像の並びの仕組みが変わっているようでそれにJINテーマが対応していないだけのようなので、今後JINが対応するまでダウングレードして待ってみるのもいいかもしれませんね。(というかそれしか方法がない・・)

新しいバージョンってことごとく試したくなるのですが、やはり不具合や不便な点が出てくるのも否めません。

今回知ったプラグインで過去のバージョンに戻せることが分かったので、これからもバージョンするたびに不具合があれば戻せるようになりますね!逆になんで今まで知らなかったんだろうというほど便利なプラグインですw